Home / Security / USN-4270-1: Exiv2 vulnerability | Ubuntu security notices

USN-4270-1: Exiv2 vulnerability | Ubuntu security notices

5 February 2020

exiv2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Exiv2 could be made to crash if it opened a specially crafted image.

Software Description

  • exiv2 – EXIF/IPTC/XMP metadata manipulation tool

Details

It was discovered that Exiv2 incorrectly handled certain images.
An attacker could possibly use this issue to cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
exiv20.25-4ubuntu2.2
libexiv2-140.25-4ubuntu2.2
Ubuntu 18.04 LTS
exiv20.25-3.1ubuntu0.18.04.5
libexiv2-140.25-3.1ubuntu0.18.04.5
Ubuntu 16.04 LTS
exiv20.25-2.1ubuntu16.04.6
libexiv2-140.25-2.1ubuntu16.04.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

Source link

Leave a Reply

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.

x

Check Also

USN-4279-2: PHP regression

php7.0 regression A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 ...